Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - orgtec

Pages: [1]
1
Android Products / Re: Date and Time Formats
« on: April 08, 2014, 07:59:44 AM »
Just for an update and a way around the problem.

Since the Exact Time does not work properly, it always shows as Date & Time, in the Forms and in the Access.

I used ADDTIME(hh:mm:ss, 0,0) as an expression that is Assigned on form Startup. So when you select VisitTime to introduce the correct Visit Time, it shows the value in the Field and not the actual time Now. This way I only have to change the Hour and not the Minutes on the selector.

It becomes a minor issue, but the Mask of the Exact setup should work according to the Format that is set.

2
Android Products / Re: Date and Time Formats
« on: April 08, 2014, 05:59:06 AM »
1- Between the configuration of Access Format and Cellica Format I got them to save correctly, maybe it had to do with the initial configuration of the Profile Connection to the Database.

2- The problem still exists on the configuration of Exact for Date or Time, it does not work the way you think. I send you an Image thru the support email.

Also when you try to choose Records, using a DatTime field configured as Date only, it shows up with time as 00:00:00.

I have not figured out how to place images here on the KB.

3
Android Products / Re: Date and Time Formats
« on: April 07, 2014, 02:20:47 AM »
1) It is true that is saved as hh:mm:ssss if you dont choose any format, but when you select a specific format it stay like the format and displays like the format. The problem appears to be that Cellica always saves like hh:mm:ss regardless of format.

2) The field is already specified as time but it still asks for Date and Time in full. It should be that if you specify Date, the entry of fixed should be dd-mm-yyyy, if you specify Time should be hh:mm, and if you specify Date & Time then it should be dd-mm-yyyy hh:mm. It isn't what is happenning

3)I understand now that it is 2 strings at a time, but the Macro PDF does not say that.

4) I'm not using a Find button, I'm using a Combobox with the VisitDate as Source to filter the Subform that has a Grid from the Visit Records. The Combobox shows all records, repeated VisitDates with Date & Time, where Time now is equal to 00:00. Before it showed Time equal to whatever it was recorded which only filtered one result, It appears that now is recording Date & Time with Time as 00:00 and it filters ok. As long has it stays like that the filter works.

Thanks

4
Android Products / Re: Double Click
« on: April 07, 2014, 02:00:15 AM »
Using a button was obvious choice that I had done already.

What I asked was from a List of Clients grid, double click on the line and Open the Client Record.

Thanks

5
Android Products / Date and Time Formats
« on: April 05, 2014, 04:40:42 PM »
I'm trying to get some Date and Time Formats to be used in a consistent manner and I'm having some trouble.

I have configured in Access 2 fields, VisitDate formatted and fixed like dd-mm-yyyy and VisitTime formatted and fixed like hh:mm.

I have tried several things but nothing seems to work on Android Form, Empty field, Fixed Field etc, it always syncs like dd-mm-yyyy hh:mm:ss for both fields.

I have configured on Form VisitDate as Date only, and it shows only Date as dd-mm-yyyy and also configured VisitTime as Time only and it shows hh:mm:ss.

If I try do configue VisitTime as Fixed it forces me to put in dd-mm-yyyy hh:mm:ss in full.

I also tried to convert VisitTime to String and tried to Concatenate(Hour(VisitTime),":",Minute(VisitTime)) to see  I could get around it, no go, Concatenate does not like the ":".

Do you have a way to correctly use the format that is in Access?

The problem of all this is that when I try to filter on a VisitDate to see all the the VisitTimes, only the one that has the Date and Time correct works. If I have 4 visits only one shows up.

Help

6
Android Products / Close Active Form
« on: April 05, 2014, 11:46:40 AM »
How can I close the existing active form so that I go back to Parent Form?

If I close Parent before entering Child Form, I loose the existing filter that was set.

If I dont't close Parent, open Child, do the work and then open Parent form , it opens a new Parentl ike , not the still open Parent.

help

7
Android Products / Find Button
« on: March 16, 2014, 09:18:37 AM »
Good Morning,

Put a Find button on a Clients form, if I access form direct it works fine.

If I access thru a previous Salesman filter form, the button does not appear, why? Bug?

Thanks

8
Android Products / Sugestions for Device app
« on: March 16, 2014, 09:15:50 AM »
It would be nice if on the device side, Forms and Profiles, it showed for each item the date of last sync and status like Syncked, Syncking, or icon with green check mark for done, yellow for online with host and red for not syncked.

thanks


9
Android Products / Double Click
« on: March 16, 2014, 08:53:00 AM »
Good Morning

Is there a Double Click  Event to run a Macro?

I need to to open a form after selecting a record on a  grid view passing the Reference field to the new form.

Thanks

10
Android Products / Update Record is not allowed
« on: March 16, 2014, 08:49:47 AM »
Good Morning,

I havea straight Client Table where I have some fields which I allow to be edited. Thes fields are Read Only False on the Form, all other are Read Only True.

I then hava an Edit button for these fields. Sometimes when you press the Edit, you get an error, "Update Record is not allowed, please check your subscription status on desktop." It happens mostly when you start the application on the tablet.

The form is filtered by Salesman from a prevoius Salesman choice form. So I thought that it was because it was a filtered form. If I went straight to the Client form, it worked and the if I went to the filtered Client form it worked too, but I found out that is not alwys true.

It has happen that the filtered form works for Edit and then after a few minutes it does not again.

Any suggestions?

11
Good morning again

It looks that the info on the PDF does not work......

However here is a solution that works.

On the Textbox configured for URL you should have the path configured like this

"file:///storage/sdcard0/android/data/com.dropbox.android/files/scratch/" configuration Dropbox sync.

You may put the complete path concatenated with the image filename in the Data Record or use Prefix for the specific path and just the filename in the Record, must use extension.

Hope to help other users.

12
Good Morning

I have tried the information in the PDF, no go.

Tried to put the JPG images in the /mnt/sdcard, tried to put a prefix "/mnt/sdcard/" with Txtbox setup as URL, nothing.

Im using the temporary Anywhere version 3.0.0 on Desktop and 3.0.5 on Android

When you tap the Android Textbox, it shows the name of the image file with the JPG extension, but it says it cannot find it. There is no Help button on the Frame that is shown, unlike its shown on the PDF file on page 9.

Thanks

13
The Form Designer is missing the Container component from the Control List. Is it because it needs the add-on? can you send to me if thats the case?

Also about the Unbound control, how do choose de Logo image file? don't have option to insert path.

If the Add-on is not available, then how do you configure the path in the URL format for accessing Dropbox directory? Does it have quotes? Does it have double slash in beggining? Not explained in manual.

this is the directory and file link that I want to open:
/sdcard/android/data/com.dropbox.android/files/scratch/imagens/30898836324.jpg

I have tried to put /sdcard/android/data/com.dropbox.android/files/scratch/imagens/ as the the Prefix but nothing as well, it says it cannot find the file

Thanks

14
Tanks for the help, did resolve initial issues that were indicated.

15
Hello,
I'm trying to make a Form with 4 Tabs with the follwing functions:

Tab1- Choice of Salesman as a base for the other Tabs. Salesman Profile, Table Salesman
Tab2- Clients based on Salesman choice in Tab 1 in a subform. Client Profile, Table Clients
Tab3- Articles- List of Articles based on choice of Family, put Article in a subform linked to Family. On choice of Article, shows availability from stocks. Profile Articles, Profile Family, Tables Family and Articles
Tab4- Stocks- List of Articles with availabilty. Profile Stocks, Table Stocks

Eventually create a Tab5 for Order by Client choice in Tab2, acumulation based on choice of Article on Tab3.

What it looks is that after I associate first Profile with Form, I cannot associate any more profiles, unless I put the second Profile in a subform.

So Tab 1 and 2 will work, but 3 and 4 does not because I cannot use a subform within a subform on Tab3 and Stocks has nothing to do with the initial coosen Profile.

How to get around this?

Hope I made myself clear.
I can provide a file with images of the Cellica manager and forms.

orgtec@orgtec.pt

Thanks in advance for the help.
Carlos

Pages: [1]